Startseite   |  Site map   |  A-Z artikel   |  Artikel einreichen   |   Kontakt   |  
   
  •  
    Biologie
    Themen der Chemie
    Deutsch online artikel
    Englisch / Englische
    Franzosisch
    Geographie
    Geschichte
    Informatik
    Kunst
    Mathematik / Studium
    Musik
    Philosophie
    Physik
    Recht
    Sport
    Wirtschaft & Technik



    Biographie

    Impressum

informatik artikel (Interpretation und charakterisierung)

Tcp/ip-anwendungen und tcp/ip konfigurieren


1. Java
2. Viren



Übung TCP/IP-Kommandos: Probieren Sie folgenden Kommandos auf dem Rechner l1:

ping, /usr/sbin/traceroute, finger, domainname, hostname, mail, telnet, ftp

Verwenden Sie die Manualpages unter linux.

Betrachten Sie die Homepage www.htlwrn.ac.at.

Übung TCP/IP-Konfiguration: Dokumentieren sie handschriftlich das Netzwerk der HTL, die folgende
Dateien bzw. Kommandoausgaben enthält. (Ziehen Sie auch die Manualseiten zu Rate.
Auszüge der Datei /etc/hosts finden Sie weiter oben)

 l1: /etc/hosts, /etc/rc.config (Hilfe im yast), /etc/gateways(routing-table), /etc/exports(NFS)
Kommandoausgabe von: /sbin/route, /sbin/ifconfig, /sbin/arp -a

 sun: /etc/netmasks, /etc/defaultdomain, /etc/defaultrouter, /etc/named.data/named.hosts,

Kommandoausgabe von /usr/bin/netstat -r


 cisco


 dos: net.cfg


 windows: trumpet winsocket


2.6.1 l1:/etc/rc.config:

#

# /etc/rc.config
#
# Copyright (c) 1996 S.u.S.E. GmbH Fuerth, Germany. All rights reserved.
#
# Configuration database for shell scripts in /sbin/init.d, /sbin/SuSEconfig
# Hinweis: Diese Datei wird mit dem Konfigurationswerkzeug YAST bearbeitet
# Es sind nur die TCP/IP-Einträge vorhanden
# Also don\'t forget to edit the following files:

# - /etc/lilo.conf
# - /etc/fstab

# - /etc/profile
# - /etc/hosts
#
# start loopback networking? (\"yes\" or \"no\")

START_LOOPBACK=yes
# number of network cards: \"_0\" for one, \"_0 _1 _2 _3\" for four cards
#
IPADDR_0=\"193.170.149.155\"

IPADDR_1=\"\"

#
# network device names (e.g. \"eth0\")
#
NETDEV_0=\"eth0\"

NETDEV_1=\"\"
#
# parameteres for ifconfig, if you put \"bootp\" into it, bootp will
# be used to configure it

# sample entry for ethernet:
IFCONFIG_0=\"193.170.149.155 broadcast 193.170.149.159 netmask 255.255.255.224\"

IFCONFIG_1=\"\"
#
# network address of the devices (e.g. \"-net 192.168.81.32\" or
# \"-host 192.168.81.33\")
#
NETWORK_0=\"193.170.149.128\"

NETWORK_1=\"\"
#
# if this is set, the default route will be set to this gateway
# (e.g. \"192.168.81.33\")
#
GATEWAY_0=\"193.170.149.156\"

GATEWAY_1=\"\"
#
# setup dummy network device for IPADDR_0? this is useful for non permanent
# network connections (e.g. SLIP, PPP). Some software needs a connection

# to FQHOSTNAME (e.g. plp). (yes, no)
SETUPDUMMYDEV=yes
#
# hostname of the system (full name)
# if zero, and bootp is used above, bootp will also set the hostname
# (e.g. \"riemann.suse.de\" or \"hugo.linux.de\")
# don\'t forget to also edit /etc/hosts for your system
#

FQHOSTNAME=linux1

#
# domain searchlist that should be used in /etc/resolv.conf
# (e.g. \"suse.de linux.de uni-stuttgart.de\")
# Attention! this has to be filled out, if you want to access a name server
#
SEARCHLIST=\"sun.htlwrn.ac.at\"
#
# space separated list of nameservers that should be used for /etc/resolv.conf

# give a maximum of 3 IP numbers
# (e.g. \"192.168.116.11 192.168.7.7\")
#
NAMESERVER=\"193.170.149.151\"

# News server.
NNTPSERVER=\"linux1.htlwrn.ac.at\"
# start the inet daemon in multi-user? (\"yes\" or \"no\")
# this is needed, if you have to telnet/rlogin to your own machine.

START_INETD=yes
# start portmap? (\"yes\" or \"no\")
# this is needed, if the NFS server is started or if NIS is used
START_PORTMAP=yes
# should the NFS server be started on this host? (\"yes\" or \"no\")
NFS_SERVER=yes
# start the apache www-server in /local/www/sbin/httpd? (\"yes\" or \"no\")
START_HTTPD=yes



2.6.2 l1: /etc/exports:


#exports
/home www(rw)

2.6.3 l1:Ausgabe von /sbin/route:

Kernel routing table
Destination Gateway Genmask Flags Metric Window Use Iface
ipnet1 * 255.255.255.224 U 0 0 419235 eth0
loopback * 255.0.0.0 U 0 0 1675 lo
default Firei 0.0.0.0 UG 1 0 46553 eth0

2.6.4 l1:Ausgabe von /usr/sbin/traceroute:

1 Firei (193.170.149.156) 1.995 ms 1.724 ms 1.704 ms
2 htlwrneu-server (193.170.149.189) 4.516 ms 4.534 ms 4.34 ms
3 193.170.149.5 (193.170.149.5) 36.378 ms 28.177 ms 28.198 ms
4 gw2.bmuvie.gv.at (193.170.115.9) 30.645 ms 30.418 ms 30.428 ms
5 Vienna-RBS.ACO.net (192.153.182.57) 31.213 ms 40.41 ms 31.041 ms
6 iris.cc.univie.ac.at (193.171.14.11) 31.518 ms 34.108 ms 31.682 ms
7 hera.cc.univie.ac.at (131.130.208.2) 31.505 ms 31.454 ms 31.381 ms
8 ftp.univie.ac.at (131.130.1.4) 33.506 ms 32.104 ms 34.245 ms


2.6.5 l1:Ausgabe von /sbin/ifconfig:


eth0 Link encap:10Mbps Ethernet HWaddr 00:40:C7:55:21:C0
inet addr:193.170.149.155 Bcast:193.170.149.255 Mask:255.255.255.224
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1643374 errors:0 dropped:0 overruns:0
TX packets:1663116 errors:0 dropped:0 overruns:0
Interrupt:11 Base address:0x340

2.6.6 l1:Ausgabe von /usr/sbin/arp -a und ping

Address HW type HW address Flags Mask

193.170.149.150 10Mbps Ethernet 00:00:0C:3D:DA:7A C *
193.170.149.151 10Mbps Ethernet 08:00:20:74:FA:7E C *
193.170.149.158 10Mbps Ethernet 00:60:8C:96:EC:10 C *


PING localhost (127.0.0.1): 56 data bytes
64 bytes from 127.0.0.1: icmp_seq=0 ttl=64 time=0.3 ms
64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.2 ms


--- localhost ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss

round-trip min/avg/max = 0.2/0.2/0.3 ms


2.6.7 sun:/etc/netmasks:

#

# network-number netmask
#

193.170.149.0 255.255.255.224


2.6.8 sun:/etc/defaultdomain:


htlwrn.ac.at


2.6.9 sun:/etc/defaultrouter:


193.170.149.150


2.6.10 sun:/etc/named.data/named.hosts:

; named.hosts 19960205;
; CONTACT should be an username who feels responsible for the DNS .
; change all uppercase tokens to Your local names ....
;

@ IN SOA sun.htlwrn.ac.at. root.sun.htlwrn.ac.at. (

1995092738; Serial
3600 ; Refresh every hours

1800 ; Retry every hour
604800 ; Expire after a week

86400 ) ; Minimum ttl of 1 day



IN NS sun.htlwrn.ac.at.
IN NS ns1.univie.ac.at.
ns1.univie.ac.at. IN A 131.130.1.11
htlwrneu-server IN A 193.170.149.150 ; CISCO Router
lb IN A 127.0.0.1
;
;mailhost IN A 131.130.1.19

localhost IN CNAME lb.htlwrn.ac.at.
sun IN A 193.170.149.151 ; Sun

dns IN CNAME sun
;
; Segment ZUSE (IP: 193.170.149.33 - 193.170.149.62)
n1 IN A 193.170.149.62

u101 IN A 193.170.149.33
...

u122 IN A 193.170.149.54
; segment ZEMANEK (bonus computer)

WWW IN A 193.170.149.154 ;Www
Linux1 IN A 193.170.149.155; Linux1 linux1 l1 L1

l1 IN CNAME Linux1

IN MX 10 sun.htlwrn.ac.at.
IN MX 100 email.univie.ac.at.
ppp-host IN A 193.170.149.193

2.6.11 sun:Ausgabe von usr/bin/netstat -r:

Routing Table:
Destination Gateway Flags Ref Use Interface
---------------------- -------------------- ----- ----- ------ ---------
localhost localhost UH 0 1727 lo0
ipnet4 SUN U 3 305 le0
193.170.149.192 ppp-host U 2 0 ipd1
BASE-ADDRESS.MCAST.NET SUN U 3 0 le0
default CISCO UG 0 3192


2.6.12 CISCO (Internet-Router)

interface Ethernet0
description Lokales Ethernet HTL Wr. Neustadt
ip address 193.170.149.150 255.255.255.224

!
interface Serial0
description 64 Kbit Verbindung HTL-Wien 5
ip address 193.170.149.6 255.255.255.252

bandwidth 64

!

ip domain-name htlwrn.ac.at
ip name-server 193.170.149.151

ip route 0.0.0.0 0.0.0.0 193.170.149.5
ip route 193.170.149.32 255.255.255.224 193.170.149.158
ip route 193.170.149.64 255.255.255.224 193.170.149.158
ip route 193.170.149.96 255.255.255.224 193.170.149.158
ip route 193.170.149.192 255.255.255.224 193.170.149.151
2.6.13 LAN WORKPLACE FOR DOS, NET.CFG :

Link driver DE-200

Protocol IPX 0 Ethernet_802.3

Protocol IPX 8137 Ethernet_II
Port 320

Int 5

Netware Dos Requester

preferred server = NETWARE
file handles = 70
Protocol TCPIP
PATH SCRIPT n:\\lwp\\SCRIPT

PATH TCP_CFG n:\\lwp\\TCP
ip_netmask 255.255.255.224

ip_address 193.170.149.142
ip_router 193.170.149.158


2.6.14 TRUMPET WINSOCK


Trumpet Winsock Version 2.1 Revision F
Ethernet address = 00:80:C8:24:30:1C
WINPKT packet driver located on vector $62
IP buffers = 32 Packet buffers = 16
My IP = 193.170.149.142 netmask = 255.255.255.224 gateway = 193.170.149.150

 
 




Datenschutz

Top Themen / Analyse
Wer kann ICANN-Mitglied werden?
IMesh
Kopplung = Coupling
Betriebssysteme bis 1998
Interpolationssuche (interpolation search)
Farbmodelle definieren Farbe mathematisch
Informationssuche (ARCHIE)
Werteinträge in der Registry
Systembusse
Die MIDI-Daten:





Datenschutz

Zum selben thema
Netzwerk
Software
Entwicklung
Windows
Programm
Unix
Games
Sicherheit
Disk
Technologie
Bildung
Mp3
Cd
Suche
Grafik
Zahlung
Html
Internet
Hardware
Cpu
Firewall
Speicher
Mail
Banking
Video
Hacker
Design
Sprache
Dvd
Drucker
Elektronisches
Geschichte
Fehler
Website
Linux
Computer
A-Z informatik artikel:
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z #

Copyright © 2008 - : ARTIKEL32 | Alle rechte vorbehalten.
Vervielfältigung im Ganzen oder teilweise das Material auf dieser Website gegen das Urheberrecht und wird bestraft, nach dem Gesetz.